Issue Summary
We have seen a number of cases of network loops are being formed when connecting more than one Sonos speaker to Plume. Network loops can cause a plethora of issues on a LAN, and often cause inaccurate or failed optimizations and instability.
When a network loop is present, the NOC/Plume Central will show normally static devices changing their connections and sometimes they may even show themselves connected to two pods at once. Another sign that a network loop is present is an extreme amount of activity in a switch or router's LEDs caused by the broadcast storm. Do not rely on being able to identify a loop with these behaviors though. Knowing how connections are made is always the best way to identify a potential loop.
Cause
Sonos Speakers are capable of being connected both by Ethernet and 2.4 GHz Wi-Fi and can also connect together to create their own separate mesh network, called SonosNet, over WiFi.
When you have multiple Sonos speakers wired to different pods, the Sonos speakers will try to connect using the Ethernet port, however they will not find a "master" speaker. The speaker will then check WiFi, and find the "master" speaker and connect by WiFi in addition to the Ethernet. When this happens, the speaker inadvertently bridges that WiFi connection to its own Ethernet port, and if the leaf pod comes online, a bridging loop is caused.
Solution
There are a few solutions to this issue:
- Connecting ALL Sonos speakers via WiFi to the Plume network avoids any bridge looping issues.
- This setup works perfectly, with the exception of possible temporary disconnections of some of the speakers during optimization. These disconnections are very short, but can be noticeable as the music may stop and the speakers ungroup, be sure to inform the customer of this possibility.
- If you want to connect your Sonos players to your Plume network using WiFi, it is also important to make sure that the Sonos firmware is updated to version 45.1-56150 or later. Speakers running older versions of Sonos firmware connected over WiFi will cause the players to lose their connection whenever the Plume network optimizes and sends out a Channel Switch Announcement (CSA), sometimes requiring a manual reconnect.
- If the customer insists on using Ethernet, they can wire only one Sonos speaker to a leaf Pod. This will allow the rest of the Sonos speakers to connect to each via SonosNet, effectively mitigating any risk of a network loop occurring.
- Only if the customer is still using their own router and running Plume in Bridge Mode can all Sonos speakers be connected by Ethernet. In this case, the Sonos speakers must be connected completely upstream of the Plume network, either directly to the router or through a switch connected to the router.