問題の概要
Plumeに2台以上のSonosスピーカーを接続したときにネットワークのループが形成されるというケースが複数報告されています。ネットワークループはLANに過度の問題を与える原因となり、最適化が不正確になるか失敗し不安定になることをよく引き起こします。
ネットワークループが存在しているときには、NOC/Frontline Tier 1では通常、静的デバイスの接続が変更されることが示され、ときにはデバイス自身が同時に2台のpodに接続されていることが示されることがあります。ネットワークループが存在する別の兆候は、ブロードキャストストームを原因とするスイッチまたはルーターの極端な量のアクティビティです。しかし、ループを特定できるようにするためには、このような挙動だけに頼らないでください。接続がどのように行われているかを理解することが、どのような場合でも、潜在的なループを特定するための最良の方法です。
原因
SonosスピーカーはEthernetと2.4 GHz Wi-Fiの両方に接続する機能があり、両方を一緒に接続してSonosNet over Wi-Fiと呼ばれる独自の別々のメッシュ型ネットワークを作成することもできます。
さまざまなpodに複数のSonosスピーカーを有線接続しているときに、Sonosスピーカーは、「マスター」スピーカーが見つからないにも関わらず、Ethernetポートを使用して接続を試みます。スピーカーは次にWi-Fiを確認し、「マスター」スピーカーを見つけ、Ethernetに加えてWi-Fiでも接続します。このようなことが起こると、スピーカーはWi-Fi接続を自分のEthernetポートに意図せずブリッジしてしまい、リーフpodがオンラインになると、ブリッジループの原因となります。
解決策
この問題に対していくつかの解決策があります:
- PlumeネットワークにすべてのSonosスピーカーをWi-Fi経由で接続することにより、ブリッジループ問題を回避します。
- この設定は、最適化の間にスピーカーの一部が一時的に切断される可能性があることを除き、完全に機能します。このような切断は非常に短時間ですが、音楽が止まりスピーカーのグループが解除されるため気づくことがあります。この可能性についてはお客様に必ず説明してください。
- Wi-Fiを使用してお使いのSonosプレーヤーとPlumeネットワークとを接続したい場合は、Sonosファームウェアがバージョン45.1-56150以降に更新されていることを確認することも重要です。Sonosファームウェアの古いバージョンを搭載したスピーカーがWi-Fiで接続すると、Plumeネットワークが最適化を行い、チャネル切り替え通知(CSA)を送出するごとに、プレーヤーが接続を失う原因となり、ときには手動での再接続が必要となる場合があります。
- お客様がEthernetの使用に固守するのであれば、1リーフPodにつき1台のSonosスピーカーのみ優先接続してください。これにより、残りのSonosスピーカーがそれぞれSonosNet経由で接続でき、ネットワークループの発生リスクを実質的に緩和します。
- お客様自身のルーターをまだ使用していてPlumeがブリッジモードで実行されているときにのみ、すべてのSonosスピーカーをEthernetに接続できます。このケースでは、Sonosスピーカーはルーターに直接か、ルーターに接続されたスイッチを通じて、Plumeネットワークの上流側に完全に接続されていなければなりません。